Thursday, May 7, 2009

HOWTO: Stable Xephyr on Ubuntu 9.04 for Fremantle SDK

As stated in the Fremantle SDK Installation Notes, Xephyr on Ubuntu 9.04 crashes when clicking on a text field in the Fremantle Beta SDK. It also says that the Intrepid (Ubuntu 8.10) version works better. Here is how you can compile and install Intrepid's Xephyr version:

sudo apt-get build-dep xserver-xephyr
sudo apt-get install build-essential devscripts
dpkg-source -x xorg-server_1.5.2-2ubuntu3.dsc
cd xorg-server-1.5.2/
cd ..
sudo dpkg -i xserver-xephyr_1.5.2-2ubuntu3_i386.deb
Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac &

Now you can start the Fremantle Beta SDK and run it without crashing all the time :) You can delete the rest of the .deb packages created - they are not needed for Xephyr. If you want to go back (well... "forward" really) to Jaunty's Xephyr package, you can simply use sudo aptitude install xserver-xephyr to upgrade it.

No comments:

Post a Comment